<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>SmartPool: Practical decentralized mining | the morning paper</title>
<!--[if lt IE 8]><link rel="stylesheet" type="text/css" media="screen" href="https://s0.wp.com/wp-content/themes/pub/vigilance/stylesheets/ie.css" /><![endif]-->
<!--[if lte IE 6]><link rel="stylesheet" type="text/css" media="screen" href="https://s0.wp.com/wp-content/themes/pub/vigilance/stylesheets/ie6.css" /><![endif]-->
<link rel="pingback" href="https://blog.acolyer.org/xmlrpc.php" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=blog.acolyer.org&amp;id=23592848&amp;t=1504777370&amp;back=https%3A%2F%2Fblog.acolyer.org%2F2017%2F09%2F07%2Fsmartpool-practical-decentralized-mining%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//adriancolyer.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="the morning paper &raquo; Feed" href="https://blog.acolyer.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="the morning paper &raquo; Comments Feed" href="https://blog.acolyer.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="the morning paper &raquo; SmartPool: Practical decentralized&nbsp;mining Comments Feed" href="https://blog.acolyer.org/2017/09/07/smartpool-practical-decentralized-mining/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1496863874h&ver=4.8.1-RC2-41203"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJyNktFuwyAMRX9oHspWbevDtG8hxKVuDUbBaZq/H2kaTe0q1BfkCz4212DGBE6iYlQTBkg8eIrZjMlJgByIcbpTry7nF/MYYzpiNgfUZN0RLqqW3iNbxQ6SZL1TNYzijiLpZHSPofRLQ2tO5IltdFgDnfRY9kOyOmcE7MgilxpRa9hIncdywZJyjUHxXEVC+lgbzeG+jKNqaZlw26Yec4ayBhoCLP7+cY9sm6wTV82vLlTSdeBPI1kcWQYqKbdigclE0eVwDWpVPQqwOKsk8UbAji319Q/TsvgS+stj/MkZ+gnfzWb7+fbVNO/N4RdKIRMo' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-1-1' href='https://s0.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJx9i9EKwjAMRX/IGoVN54P4LVnp2kialCbD3xcfRGTi0z0XzoFHC1HFkzjUNTReM4kBRieVGfuH9tFsB7/1puZhYaQOVrCT5Pf+q0wjIQfWrN9nE3lJNRmUATLrjPwSbvV6HC6H83Qap/H+BMWZScE=' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFj90KwjAMhV/IrAw6xQvxWWoXS2r/bNoNfXo70At1KARCTr4cTsScgIJ2dUQWttW1Yr49W2d5I34B4MlkVbDzFF6wjqFgKAvr44kcQmXMyjStGZ3jCpciF4/MDVrZvkeiMBHOfzGLJSl9gYxM9y9XXyG5aiiwyOjaAyMsGT6mdnX0h17uh36Qcre1DyuucHk='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://adriancolyer.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='REM: Resource-efficient mining for&nbsp;blockchains' href='https://blog.acolyer.org/2017/09/06/rem-resource-efficient-mining-for-blockchains/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://blog.acolyer.org/2017/09/07/smartpool-practical-decentralized-mining/" />
<link rel='shortlink' href='http://wp.me/p1AZzO-1pV' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fblog.acolyer.org%2F2017%2F09%2F07%2Fsmartpool-practical-decentralized-mining%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fblog.acolyer.org%2F2017%2F09%2F07%2Fsmartpool-practical-decentralized-mining%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="SmartPool: Practical decentralized mining" />
<meta property="og:url" content="https://blog.acolyer.org/2017/09/07/smartpool-practical-decentralized-mining/" />
<meta property="og:description" content="SmartPool: Practical decentralized pooled mining Luu et al., USENIX Security 2017 Say you wanted to implement a mining pool that didn&#8217;t place power in the hands of centralized pool operators.…" />
<meta property="article:published_time" content="2017-09-07T05:00:00+00:00" />
<meta property="article:modified_time" content="2017-08-31T09:01:19+00:00" />
<meta property="og:site_name" content="the morning paper" />
<meta property="og:image" content="https://adriancolyer.files.wordpress.com/2017/08/smartpool-fig-4.jpeg?w=640" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wordpressdotcom" />
<meta name="twitter:text:title" content="SmartPool: Practical decentralized&nbsp;mining" />
<meta name="twitter:image" content="https://adriancolyer.files.wordpress.com/2017/08/smartpool-fig-2.jpeg?w=240" />
<meta name="twitter:card" content="summary" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/09326a066a08237015d6b84f026d36ae?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/09326a066a08237015d6b84f026d36ae?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/09326a066a08237015d6b84f026d36ae?s=114" />
<link rel='openid.server' href='https://adriancolyer.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://adriancolyer.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://blog.acolyer.org/osd.xml" title="the morning paper" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<style id="wpcom-hotfix-masterbar-style">
			@media screen and (min-width: 783px) {
				#wpadminbar .quicklinks li#wp-admin-bar-my-account.with-avatar > a img {
					margin-top: 5px;
				}
			}
		</style>
		
	<meta name="application-name" content="the morning paper" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="an interesting/influential/important paper from the world of CS every weekday morning, as selected by Adrian Colyer" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://blog.acolyer.org/feed/;icon-uri=https://secure.gravatar.com/blavatar/09326a066a08237015d6b84f026d36ae?s=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="SmartPool: Practical decentralized&nbsp;mining | the morning paper on WordPress.com" />
<meta name="description" content="SmartPool: Practical decentralized pooled mining Luu et al., USENIX Security 2017 Say you wanted to implement a mining pool that didn&#039;t place power in the hands of centralized pool operators. If only there was some fully decentralised way of establishing trust and coordinating activities according to a policy, in which anyone could participate... Oh, wait,&hellip;" />
	<style type="text/css">
				#title a { color: #444444 }
		</style>
<link rel="amphtml" href="https://blog.acolyer.org/2017/09/07/smartpool-practical-decentralized-mining/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<style type="text/css" id="custom-colors-css">.comments a{background-image:none;padding-left:0}body{color:#333}.categories a:link,.categories a:visited{color:#333}#nav li a{color:#333}#footer{color:#333}#description h2{color:#333}.post .date,.comments,.meta,.categories{color:#333}.meta a:link,.meta a:visited{color:#333}#footer a:link,#footer a:visited{color:#333}.sticky .entry{background-color:#eee}.sticky .entry{background-color:rgba(238,238,238,.1)}#footer{border-color:#6d6d6d}body{background-color:#fff}.post-header,.post-footer{border-color:#fff}#header{border-color:#b7b7b7}a:hover{color:#772124}#header #title a:hover{color:#772124}#nav ul li a:hover,#nav ul li:hover>a,#nav ul li.current_page_item>a,#nav ul li.current_page_parent>a,#nav ul li.current_page_ancestor>a,#nav ul li.current-cat>a,#nav ul li.current-menu-ancestor>a,#nav ul li.current-menu-item>a,#nav ul li.current-menu-parent a{color:#772124}#nav ul li a:hover,#nav ul li:hover>a,#nav ul li.current_page_item>a,#nav ul li.current_page_parent>a,#nav ul li.current_page_ancestor>a,#nav ul li.current-cat>a,#nav ul li.current-menu-ancestor>a,#nav ul li.current-menu-item>a,#nav ul li.current-menu-parent a{border-top-color:#772124}.post-header h1 a:hover,.post-header h2 a:hover{color:#772124}.meta a:hover{color:#772124}.comments a:hover{color:#772124}.categories a:hover{color:#772124}span.asterisk{color:#772124}#footer a:hover{color:#772124}a:link,a:visited{color:#772124}.post-header h1 a:link,.post-header h1 a:visited,.post-header h2 a:link,.post-header h2 a:visited{color:#772124}#title a{color:#772124}</style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s2.wp.com/?custom-css=1&#038;csblog=1AZzO&#038;cscache=6&#038;csrev=6" />
		</head>
<body class="post-template-default single single-post postid-5451 single-format-standard mp6 customizer-styles-applied vigilance-light highlander-enabled highlander-light custom-colors">
	<div class="skip-content"><a href="#content">Skip to content</a></div>
	<div id="wrapper">
				<div id="header" class="clear">
			<div id="title"><a href="https://blog.acolyer.org"><span>the morning paper</span></a></div>			<div id="description">
				<h2>an interesting/influential/important paper from the world of CS every weekday morning, as selected by Adrian Colyer</h2>
			</div><!--end description-->
			<div id="nav">
					<ul class="menu">
		<li class="page_item "><a href="https://blog.acolyer.org">Home</a></li>
				<li class="page_item page-item-2"><a href="https://blog.acolyer.org/about/">About</a></li>
<li class="page_item page-item-5027"><a href="https://blog.acolyer.org/infoq-quarterly-review-editions/">InfoQ QR Editions</a></li>
<li class="page_item page-item-406"><a href="https://blog.acolyer.org/email-subs/">Subscribe</a></li>
	</ul>
			</div><!--end nav-->
		</div><!--end header-->
		<div id="content" class="pad">
									<div id="post-5451" class="post-5451 post type-post status-publish format-standard hentry category-uncategorized tag-blockchain">
			<div class="post-header">
				<h1>SmartPool: Practical decentralized&nbsp;mining</h1>
				<div id="single-date" class="date">September 7, 2017</div>
			</div><!--end post header-->
			<div class="meta clear">
				<div class="tags">tags: <a href="https://blog.acolyer.org/tag/blockchain/" rel="tag">Blockchain</a></div>
				<div class="author">
									</div>
			</div><!--end meta-->
			<div class="entry clear">
								<p><a href="https://www.usenix.org/conference/usenixsecurity17/technical-sessions/presentation/luu">SmartPool: Practical decentralized pooled mining</a> Luu et al., <em>USENIX Security 2017</em></p>
<p>Say you wanted to implement a mining pool that didn&#8217;t place power in the hands of centralized pool operators. If only there was some fully decentralised way of establishing trust and coordinating activities according to a policy, in which anyone could participate&#8230; Oh, wait, that sounds just like a smart contract!</p>
<blockquote><p>
  In this work, we propose SmartPool, a novel protocol design for a decentralized mining pool. Our protocol shows how one can leverage smart contracts, autonomous blockchain programs, to decentralize cryptocurrency mining.
</p></blockquote>
<p>SmartPool is both a neat idea in its own right, and also a great case study in some of the <a href="https://blog.acolyer.org/2017/09/01/step-by-step-towards-creating-a-safe-smart-contract-lessons-from-a-cryptocurrency-lab">considerations when designing smart contracts</a> that we looked at last week. If you want to follow along at home, you can find the <a href="https://github.com/SmartPool/contracts">source code for the SmartPool contract on GitHub</a>.</p>
<p>As part of their evaluation, the authors ran a SmartPool mining pool for a week with a peak hashrate of 30 GH/s, and mined 105 blocks costing miners just 0.6% of block rewards in transaction fees. Compare this to the 3% typically taken by centralized pools. (At the exchange rate on the day I&#8217;m writing this, 105 blocks comes out at just shy of $200K in miner rewards.)</p>
<h3>Why do we care about decentralized mining pools?</h3>
<p>The whole point was to be decentralized, but over time mining pools have come to hold increasing power in the Bitcoin and Ethereum networks: Bitcoin derives 95% of its mining power from just 10 pools, and Ethereum gets 80% of its mining power from only 6 pools. The consolidation of power leads to potential <a href="https://blog.acolyer.org/2017/06/27/hijacking-bitcoin-routing-attacks-on-cryptocurrencies/">hijacking attacks</a>,  and threats to the core security of the Bitcoin consensus protocol if a single pool operator controls more than 51% of the mining power (as has happened in both Ethereum and Bitcoin on several occasions &#8211; e.g. DwarfPool and GHash.io respectively).</p>
<p>Pools can also dictate which transactions get included in the blockchain, increasing the threat of transaction censorship or favouring their own blocks.</p>
<blockquote><p>
  For example, users recently <a href="https://www.reddit.com/r/ethereum/comments/6itye9/collecting_information_about_f2pool/">publicly speculated</a> that a large Ethereum pool favored its own transactions in its blocks to gain an advantage in a public crowdsale.
</p></blockquote>
<p>And then of course there are the comparatively hefty fees (~3%) to be paid to pool operators.</p>
<p>In Bitcoin, one decentralized mining pool solution does exist, called <a href="http://p2pool.org/">P2Pool</a>, but as the authors demonstrate it suffers from a lack of scalability and has not been widely adopted.</p>
<h3>Challenges for a decentralized mining pool</h3>
<blockquote><p>
  We consider the problem of building a decentralized protocol which allows a large open network to collectively solve a computational PoW puzzle, and distribute the earned reward between the participants proportional to their computational contributions.
</p></blockquote>
<p>Such a protocol should be <em>decentralised, efficient, secure</em>, and <em>fair</em>.</p>
<ul>
<li>Decentralised &#8211; there should be no central operator managing the pool and its participants.</li>
<li>Efficient &#8211; running costs should be low and the variance and rewards for miners should be comparable to centralized solutions. Overheads and other costs (e.g., gas costs) incurred by participants must be reasonably small</li>
<li>Secure &#8211; protection from attackers wanting to steal rewards, game the system,  or prevent others from joining</li>
<li>Fair &#8211; participants should receive rewards in proportion to their share of the contributions. </li>
</ul>
<p>Assume a threat model in which miners are rational and can deviate arbitrarily from the honest protocol to gain more reward.</p>
<h3>SmartPool high-level overview</h3>
<blockquote><p>
  At a high level, SmartPool replaces the mining pool operator with a smart contract. The smart contract acts as a trustless bookkeeper for the pool by storing all shares submitted by miners. When a new share is submitted, the contract verifies the validity of the share, checks that no previous record of the share exists, and then updates the corresponding miner&#8217;s record.
</p></blockquote>
<p>Here&#8217;s a starter for 10 which shows the basics of the idea:</p>
<p><img src="https://adriancolyer.files.wordpress.com/2017/08/smartpool-fig-2.jpeg?w=480" alt="" /></p>
<p>Unfortunately this version has a number of shortcomings which we&#8217;ll need to fix (compare to e.g., <a href="https://github.com/SmartPool/contracts/blob/master/Testpool.sol">the final contract source</a>).</p>
<ol>
<li>If there are a large number of shares in the pool, then an unwieldy number of messages will be sent to the contract. For example, if it takes 1,00,000 shares to mine a block, that&#8217;s 1,00,000 transactions. But reducing the number of shares per block increases the variance in reward for miners, defeating the point of pooling.</li>
<li>The gas fees incurred for submitting shares to the pool might cause miners to end up with negative rewards overall</li>
<li>Transactions are in plaintext, so network adversaries can see the transactions of other miners and either steal or resubmit the shares. (In centralized pools, a secure and private connection to the pool can be assumed, so this issue does not exist).</li>
<li>It&#8217;s difficult to use the SmartPool for e.g. Bitcoin mining when the contract is deployed on Ethereum. The contract must guarantee correct payments in Bitcoin, but Ethereum contracts operate only in Ether. </li>
</ol>
<p>SmartPool is decentralised, efficient, secure, and fair:</p>
<ul>
<li>Decentralised &#8211; the pool is implemented as a smart contract</li>
<li>Efficient &#8211; miners submit shares in batches (e.g., 1 transaction can claim 1 million shares). Miners do not need to submit data for all of the shares, but only a few for verification purposes.</li>
<li>Secure &#8211; miners must commit the right set of beneficiary addresses in a share before mining, so that it can&#8217;t be change after a solution is found. </li>
<li>Fair &#8211; a probabilistic verification of miner submissions aided by a Merkle-tree based commitment scheme guarantees the same average outcome as running a full verification.</li>
</ul>
<p>To handle the case of Bitcoin mining on top of Ethereum, SmartPool leverages the Bitcoin coinbase transaction so that miners don&#8217;t need to trust a third party to proxy the payment. Miners do still need to pay for gas in Ether. Gas payments should be less than 1% of the total miners&#8217; reward.</p>
<blockquote><p>
  SmartPool maintains two main lists in its contract state &#8211; claim list <code>claimList</code> and a verified claim list <code>verClaimList</code>.
</p></blockquote>
<ul>
<li>When a miner submits a set of shares as a claim for the current block, it is added to the claim list. This acts as a cryptographic commitment to the shares claimed to be found by the miner.</li>
<li>SmartPool verifies the validity of the claim, and once verified, moves it to the verified claim list. Claim verification and payments for verified claims happen in a single atomic transaction.</li>
</ul>
<p>Submitted claims therefore need to include sufficient metadata for verification purposes. Enabling efficient verification is one of the key contributions of the paper.</p>
<blockquote><p>
  The goal of the verification process is to prevent miners from both submitting invalid shares and over-claiming the number of shares they have found.
</p></blockquote>
<p>The claim data structure is a cryptographic commitment to the shares being claimed, based on an augmented Merkle tree structure we&#8217;ll look at next. We want to verify that (i) all submitted shares are valid, (ii) no share is repeated twice in a claim, and (iii) each share appears in at most one claim.</p>
<blockquote><p>
  For efficiency, SmartPool uses a simple but powerful observation: if we <em>probabilistically verify</em> the claims of a miner, and pay only if no cheating is detected, then expected payoffs of cheating miners are the same or less than those of honest miners. In effect, this observation reduces the effort of verifying millions of shares down to verifying one or two!
</p></blockquote>
<p>Here&#8217;s the high level intuition. Consider a cheating miner submitting a claim to 1000 shares, but which contains only 500 valid shares. If SmartPool randomly samples only one share, then the odds of the cheating being detected are 1/2. <em>If the miner is caught cheating, they get paid nothing</em>. If he gets lucky and is not detected, he gets rewarded for 1000 shares. Hence the expected payoff is still 500 &#8211; exactly the same as if an honest miner claimed the right number of shares.</p>
<blockquote><p>
  By sampling <img src="https://s0.wp.com/latex.php?latex=k+%5Cgeq+1&#038;bg=e6e5e2&#038;fg=333333&#038;s=0" alt="k &#92;geq 1" title="k &#92;geq 1" class="latex" /> times, SmartPool can reduce the probability of a cheater remaining undetected exponentially small in <img src="https://s0.wp.com/latex.php?latex=k&#038;bg=e6e5e2&#038;fg=333333&#038;s=0" alt="k" title="k" class="latex" />.
</p></blockquote>
<h3>The Augmented Merkle tree</h3>
<p>The data structure containing the submitted claims that makes all this possible is an <em>augmented Merkle tree</em>.  The Merkle tree part of this enables us to commit to a batch of shares in a single claim, the <em>augmented</em> part verifies that the committed set of claims have increasing counters. All shares must include a counter, which must be strictly increasing with each share, and the shares must be included in the tree in increasing counter order, left-to-right.</p>
<p>Here are the rules:</p>
<p>Let <img src="https://s0.wp.com/latex.php?latex=ctr&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="ctr" title="ctr" class="latex" /> be a one-to-one function mapping shares to integers. Then  an <em>augmented Merkle tree</em> for a set of objects <img src="https://s0.wp.com/latex.php?latex=S+%3D+%5C%7Bs_1%2C+s_2%2C+...%2C+s_n%5C%7D&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="S = &#92;{s_1, s_2, ..., s_n&#92;}" title="S = &#92;{s_1, s_2, ..., s_n&#92;}" class="latex" /> is a tree whose nodes <img src="https://s0.wp.com/latex.php?latex=x&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="x" title="x" class="latex" /> have the form <img src="https://s0.wp.com/latex.php?latex=%28min%28x%29%2C+hash%28x%29%2C+max%28x%29%29&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="(min(x), hash(x), max(x))" title="(min(x), hash(x), max(x))" class="latex" /> where:</p>
<ul>
<li><img src="https://s0.wp.com/latex.php?latex=min%28x%29&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="min(x)" title="min(x)" class="latex" /> is the minimum of the children&#8217;s min  (or <img src="https://s0.wp.com/latex.php?latex=ctr%28s_i%29&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="ctr(s_i)" title="ctr(s_i)" class="latex" /> if <img src="https://s0.wp.com/latex.php?latex=x&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="x" title="x" class="latex" /> is a leaf corresponding to the object <img src="https://s0.wp.com/latex.php?latex=s_i&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="s_i" title="s_i" class="latex" />).</li>
<li><img src="https://s0.wp.com/latex.php?latex=hash%28x%29&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="hash(x)" title="hash(x)" class="latex" /> is the cryptographic hash of the concatenation of the children nodes (or <img src="https://s0.wp.com/latex.php?latex=hash%28s_i%29&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="hash(s_i)" title="hash(s_i)" class="latex" /> if <img src="https://s0.wp.com/latex.php?latex=x&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="x" title="x" class="latex" /> is a leaf corresponding to the object <img src="https://s0.wp.com/latex.php?latex=s_i&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="s_i" title="s_i" class="latex" />)</li>
<li><img src="https://s0.wp.com/latex.php?latex=max%28x%29&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="max(x)" title="max(x)" class="latex" /> is the maximum of the children&#8217;s min  (or <img src="https://s0.wp.com/latex.php?latex=ctr%28s_i%29&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="ctr(s_i)" title="ctr(s_i)" class="latex" /> if <img src="https://s0.wp.com/latex.php?latex=x&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="x" title="x" class="latex" /> is a leaf corresponding to the object <img src="https://s0.wp.com/latex.php?latex=s_i&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="s_i" title="s_i" class="latex" />)      </li>
</ul>
<p>A picture is in order! Here I&#8217;m using 16-bit hashes for convenience of illustration.</p>
<p><img src="https://adriancolyer.files.wordpress.com/2017/08/smartpool-sketch.jpeg?w=640" alt="" /></p>
<p>And then after I&#8217;d drawn that, I noticed the paper also includes the following figure &#8211; but I think mine is prettier!</p>
<p><img src="https://adriancolyer.files.wordpress.com/2017/08/smartpool-fig-3.jpeg?w=520" alt="" /></p>
<p>In the figure above, to prove that share <em>c</em> has been committed, a miner has to submit two nodes <em>d</em> and <em>e</em> to SmartPool. SmartPool can reconstruct the other nodes on the path from <em>c</em> to the root. The proof for one share in a Merkle tree of height <em>h</em> contains <em>h</em> hashes.</p>
<p>Any duplicated shares in a claim will yield a sorting error in at least one path of the augmented Merkle tree.</p>
<blockquote><p>
  Thus, by sampling the tree in a constant number of leaves and checking their corresponding paths, with high probability we will detect a sorting error in the augmented Merkle tree if there is one.
</p></blockquote>
<p>To prevent miners from submitting the same shares in two different claims, things are set up so that the maximum counter value in an earlier submission is always smaller than the minimum counter of shares in a later one. For example, the pair (block-timestamp, nonce) can be used as counter in an Ethereum block.</p>
<p>To get a random seed for sampling, the hashes of future blocks can be used.</p>
<p>Here&#8217;s the full protocol so far:</p>
<p><img src="https://adriancolyer.files.wordpress.com/2017/08/smartpool-fig-4.jpeg?w=640" alt="" /><br />
(<a href="https://adriancolyer.files.wordpress.com/2017/08/smartpool-fig-4">Enlarge</a>).</p>
<h3>Is it fair?</h3>
<p>Section 4 contains an analysis proving the following theorem:</p>
<blockquote><p>
  Let A be a Merkle tree. If A is sorted, then all paths in A are valid. If A is not sorted, then every leaf containing a sorting error lies on an invalid path.
</p></blockquote>
<p>The corollaries are:</p>
<ul>
<li>Every Merkle tree has at least as many invalid paths as sorting errors among the leaves. In particular, there are at least as many invalid paths as there are duplicate values among the leaves.</li>
<li>Under the payment scheme (no payout if caught cheating), if SmartPool checks one random path in the augmented Merkle tree of a claim, the expected reward when submitting invalid or duplicate shares is the same as the expected reward when submitting only valid shares.</li>
</ul>
<p>An against an adversary;</p>
<blockquote><p>
  If an adversary controls less than 50% of Ethereum hash power, then it suffices to sample only two paths of the augmented Merkle tree based on two consecutive blocks to pay miners fairly, on average.
</p></blockquote>
<h3>Implementation details</h3>
<p>Section 6 details the implementation and the results from a week of mining. There are a few extra important details here not included in the main body of the text:</p>
<ul>
<li>The need to implement the Ethash function in the contract in order to verify that a block header satisfies the required difficulty (this accounts for a lot of the code you see in the source). </li>
<li>How to avoid paying excessive costs to store the Ethereum dataset (needed for Ethash) in the contract &#8211; storing the full dataset, which changes every four days, would cost about 3M USD/day as of June 2017! </li>
<li>How to handle coinbase transactions in Bitcoin. </li>
</ul>
<p>The appendix discusses the intriguing possibility of a cryptocurrency in which SmartPool is deployed natively as the <em>only</em> mining pool.</p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-5451" class="share-twitter sd-button share-icon" href="https://blog.acolyer.org/2017/09/07/smartpool-practical-decentralized-mining/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-5451" class="share-linkedin sd-button share-icon" href="https://blog.acolyer.org/2017/09/07/smartpool-practical-decentralized-mining/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="https://blog.acolyer.org/2017/09/07/smartpool-practical-decentralized-mining/?share=email" target="_blank" title="Click to email"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="https://blog.acolyer.org/2017/09/07/smartpool-practical-decentralized-mining/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-23592848-5451-59b1149a751ba' data-src='//widgets.wp.com/likes/#blog_id=23592848&amp;post_id=5451&amp;origin=adriancolyer.wordpress.com&amp;obj_id=23592848-5451-59b1149a751ba' data-name='like-post-frame-23592848-5451-59b1149a751ba'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>											</div><!--end entry-->
			<div class="post-footer">
				<div class="categories">from &rarr; <a href="https://blog.acolyer.org/category/uncategorized/" rel="category tag">Uncategorized</a></div>
			</div><!--end post footer-->
		</div><!--end post-->
				<div class="navigation post single clear">
			<div class="alignleft"><a href="https://blog.acolyer.org/2017/09/06/rem-resource-efficient-mining-for-blockchains/" rel="prev">&larr; REM: Resource-efficient mining for&nbsp;blockchains</a></div>
			<div class="alignright" ></div>
		</div><!--end pagination-->
		<!-- You can start editing here. -->
<div id="comments">
			<!-- If comments are open, but there are no comments. -->
		<div class="comment-number">
			<span>No comments yet</span>
		</div>
	 </div><!--end comments-->

	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/09/07/smartpool-practical-decentralized-mining/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://blog.acolyer.org/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="7a159b40fe" /><input type="hidden" name="_wp_http_referer" value="/2017/09/07/smartpool-practical-decentralized-mining/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='5451' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="bc5595a202" /></p>
<input type="hidden" name="genseq" value="1504777370" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="124"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>			</div><!--end content-->
	<div id="sidebar">
																		<ul class="thin-sidebar">			<li id="text-4" class="widget widget_text"><h2 class="widgettitle">Subscribe </h2>			<div class="textwidget"><div align="center">
<a href="http://eepurl.com/bbzPm9"><img src="https://adriancolyer.files.wordpress.com/2015/01/mail-new-icon.png?w=600"></a>
<br />never miss an issue! The Morning Paper delivered straight to your inbox.
</div></div>
		</li><li id="search-3" class="widget widget_search"><h2 class="widgettitle">Search</h2><form method="get" id="search_form" action="https://blog.acolyer.org/">
	<div>
		<input type="text" value="type and press enter" name="s" id="s" onfocus="if (this.value == 'type and press enter') {this.value = '';}" onblur="if (this.value == '') {this.value = 'type and press enter';}" />
		<input type="hidden" value="Search" />
	</div>
</form></li><li id="archives-3" class="widget widget_archive"><h2 class="widgettitle">Archives</h2>		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='https://blog.acolyer.org/2017/09/'> September 2017 &nbsp;(5)</option>
	<option value='https://blog.acolyer.org/2017/08/'> August 2017 &nbsp;(19)</option>
	<option value='https://blog.acolyer.org/2017/07/'> July 2017 &nbsp;(6)</option>
	<option value='https://blog.acolyer.org/2017/06/'> June 2017 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2017/05/'> May 2017 &nbsp;(23)</option>
	<option value='https://blog.acolyer.org/2017/04/'> April 2017 &nbsp;(11)</option>
	<option value='https://blog.acolyer.org/2017/03/'> March 2017 &nbsp;(23)</option>
	<option value='https://blog.acolyer.org/2017/02/'> February 2017 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2017/01/'> January 2017 &nbsp;(25)</option>
	<option value='https://blog.acolyer.org/2016/12/'> December 2016 &nbsp;(14)</option>
	<option value='https://blog.acolyer.org/2016/11/'> November 2016 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2016/10/'> October 2016 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2016/09/'> September 2016 &nbsp;(20)</option>
	<option value='https://blog.acolyer.org/2016/07/'> July 2016 &nbsp;(16)</option>
	<option value='https://blog.acolyer.org/2016/06/'> June 2016 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2016/05/'> May 2016 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2016/04/'> April 2016 &nbsp;(12)</option>
	<option value='https://blog.acolyer.org/2016/03/'> March 2016 &nbsp;(23)</option>
	<option value='https://blog.acolyer.org/2016/02/'> February 2016 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2016/01/'> January 2016 &nbsp;(23)</option>
	<option value='https://blog.acolyer.org/2015/12/'> December 2015 &nbsp;(10)</option>
	<option value='https://blog.acolyer.org/2015/11/'> November 2015 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2015/10/'> October 2015 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2015/09/'> September 2015 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2015/08/'> August 2015 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2015/06/'> June 2015 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2015/05/'> May 2015 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2015/04/'> April 2015 &nbsp;(14)</option>
	<option value='https://blog.acolyer.org/2015/03/'> March 2015 &nbsp;(23)</option>
	<option value='https://blog.acolyer.org/2015/02/'> February 2015 &nbsp;(23)</option>
	<option value='https://blog.acolyer.org/2015/01/'> January 2015 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2014/12/'> December 2014 &nbsp;(15)</option>
	<option value='https://blog.acolyer.org/2014/11/'> November 2014 &nbsp;(20)</option>
	<option value='https://blog.acolyer.org/2014/10/'> October 2014 &nbsp;(20)</option>
	<option value='https://blog.acolyer.org/2011/05/'> May 2011 &nbsp;(3)</option>

		</select>
		</li><li id="top-posts-3" class="widget widget_top-posts"><h2 class="widgettitle">Most read in the last few days</h2><ul>				<li>
										<a href="https://blog.acolyer.org/2017/09/06/rem-resource-efficient-mining-for-blockchains/" class="bump-view" data-bump-view="tp">
						REM: Resource-efficient mining for blockchains					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/09/05/luck-is-hard-to-beat-the-difficulty-of-sports-prediction/" class="bump-view" data-bump-view="tp">
						Luck is hard to beat: the difficulty of sports prediction					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2016/04/21/the-amazing-power-of-word-vectors/" class="bump-view" data-bump-view="tp">
						The amazing power of word vectors					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2015/04/29/applying-the-universal-scalability-law-to-organisations/" class="bump-view" data-bump-view="tp">
						Applying the Universal Scalability Law to organisations					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/09/04/the-leicester-city-fairytale-utilizing-new-soccer-analytics-tools-to-compare-performance-in-the-1516-and-1617-epl-seasons/" class="bump-view" data-bump-view="tp">
						&quot;The Leicester City fairytale?&quot;: Utilizing new soccer analytics tools to compare performance in the 15/16 and 16/17 EPL seasons					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/09/07/smartpool-practical-decentralized-mining/" class="bump-view" data-bump-view="tp">
						SmartPool: Practical decentralized mining					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/09/01/step-by-step-towards-creating-a-safe-smart-contract-lessons-from-a-cryptocurrency-lab/" class="bump-view" data-bump-view="tp">
						Step by step towards creating a safe smart contract: lessons from a cryptocurrency lab					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/08/22/javascript-for-extending-low-latency-in-memory-key-value-stores/" class="bump-view" data-bump-view="tp">
						JavaScript for extending low-latency in-memory key-value stores					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/08/11/automatic-database-management-system-tuning-through-large-scale-machine-learning/" class="bump-view" data-bump-view="tp">
						Automatic database management system tuning through large-scale machine learning					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/about/" class="bump-view" data-bump-view="tp">
						About					</a>
									</li>
			</ul></li><li id="rss_links-3" class="widget widget_rss_links"><h2 class="widgettitle">RSS</h2><ul><li><a href="https://blog.acolyer.org/feed/" title="Subscribe to Posts">RSS - Posts</a></li><li><a href="https://blog.acolyer.org/comments/feed/" title="Subscribe to Comments">RSS - Comments</a></li></ul>
</li><li id="twitter_timeline-3" class="widget widget_twitter_timeline"><h2 class="widgettitle">Live on twitter</h2><a class="twitter-timeline" data-width="225" data-height="400" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-tweet-limit="10" data-lang="EN" data-partner="jetpack" data-widget-id="519408925733425153">My Tweets</a></li>		</ul>	</div><!--end sidebar-->	<div id="footer">
		<div class="footer-liner">
			<p class="right"><a href="https://wordpress.com/?ref=footer_blog">Blog at WordPress.com.</a></p>
			<p></p>
		</div><!-- .footer-liner -->
	</div><!--end footer-->
</div><!--end wrapper-->
<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201736y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/adriancolyer.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/adriancolyer.wordpress.com\/wp-login.php?action=logout&_wpnonce=5632519ecb","homeURL":"https:\/\/blog.acolyer.org\/","postID":"5451","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"0","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="23592848" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://blog.acolyer.org" />
				<input type="hidden" id="carousel-reblog-blog-title" value="the morning paper" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="db649fe676" /><input type="hidden" name="_wp_http_referer" value="/2017/09/07/smartpool-practical-decentralized-mining/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.acolyer.org\/2017\/09\/07\/smartpool-practical-decentralized-mining\/":5451};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-linkedin' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
		});
		</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/09/07/smartpool-practical-decentralized-mining/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			<div class="recaptcha" id="sharing_recaptcha"></div><input type="hidden" name="recaptcha_public_key" id="recaptcha_public_key" value="6LcYW8MSAAAAADBAuEH9yaPcF7lWh11Iq62ZKtoo" />
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546h' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"23592848","siteName":"the morning paper","siteURL":"https:\/\/blog.acolyer.org","icon":"<img alt='' src='https:\/\/secure.gravatar.com\/blavatar\/09326a066a08237015d6b84f026d36ae?s=50&d=https%3A%2F%2Fs1.wp.com%2Fi%2Flogo%2Fwpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/vigilance","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/adriancolyer.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.acolyer.org%2F2017%2F09%2F07%2Fsmartpool-practical-decentralized-mining%2F","themeURL":"","xhrURL":"https:\/\/blog.acolyer.org\/wp-admin\/admin-ajax.php","nonce":"bd8625cc66","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"6fe4a6ab29\" \/>","referer":"https:\/\/blog.acolyer.org\/2017\/09\/07\/smartpool-practical-decentralized-mining\/","canFollow":"1","feedID":"25337874","statusMessage":"","customizeLink":"https:\/\/adriancolyer.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fadriancolyer.wordpress.com%2F2017%2F09%2F07%2Fsmartpool-practical-decentralized-mining%2F","postID":"5451","shortlink":"http:\/\/wp.me\/p1AZzO-1pV","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/blog.acolyer.org\/5451","statsLink":"https:\/\/wordpress.com\/stats\/post\/5451\/blog.acolyer.org","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Vigilance","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 1,297 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/adriancolyer.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.acolyer.org%2F2017%2F09%2F07%2Fsmartpool-practical-decentralized-mining%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.acolyer.org\/wp-admin\/admin-ajax.php","nonce":"2a4cd7e02e","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/adriancolyer.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.acolyer.org%2F2017%2F09%2F07%2Fsmartpool-practical-decentralized-mining%2F","blog_id":"23592848","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=23592848&v=wpcom&tz=1&user_id=0&subd=adriancolyer","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJx9UMtSwzAM/CEcpWUKXBg+hTGO2srxC0lu6d/XHUjJoeOTNKvd1UpwLsblpJgUvMCEJ3JYfgYvT7AaxWpKqAdKAoFmFPiuWPFo0xSQFzIlF+rUhs3I5Rib0DCWcBkipY6jRy3WzfDZDEDPpIpslCIGStjR2an5mi/LEK00TetMPiEz3ULcsZ6DU8rp5nDvHh0j5T//GvftC3z5K8Oa9WCXs5yrYFjONQvQyzeTRFTzPIy/39lnjh1+yaJmHywxyNEypcNSm+gjvm924/blbfO6Hf0VhlW8gQ=='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'23592848','blog_tz':'1','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'23592848','v':'wpcom','tz':'1','user_id':'0','post':'5451','subd':'adriancolyer'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGRVYVNrSFguN3FwSmQ5RGtNX3VQcj1yVzhiflM1THQtLGFdQ2toOXYlNCVaeklqTUlaNm1kY3ZwbnZlLFpPP2pvM0ZDJnddMFdiNndIMGE0Z0xkRSxyNWx6a1VIMXw1Smd5fi5PPXNjZW4mZlozLSx8ME5iZFN4Tmp5MVRTVHk5cTZzfCsyUmpZVTlGQ0RPY0V6bUFrTDdBdVJ+fmUxSTVscy1VN1tiMHw1NXFwWzhIMTNoX0RrV09nYTQ0Vkp1ZHpyZndGaXQ/LEM4UVdPOGVqQ3JdZThKP3F6JjRGMS1tTHZlc3FsdHVPZWRdLz9jZU9qN2M2dXlbbXpHLzJtYngsVGRjcS1lSi9sJnorckhUWkFFZTkuNmJfcyxHb0ZqTEtoPU1ST1IuMlUu'}]);
_stq.push([ 'clickTrackerInit', '23592848', '5451' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>