<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Computing machinery and intelligence | the morning paper</title>
<!--[if lt IE 8]><link rel="stylesheet" type="text/css" media="screen" href="https://s0.wp.com/wp-content/themes/pub/vigilance/stylesheets/ie.css" /><![endif]-->
<!--[if lte IE 6]><link rel="stylesheet" type="text/css" media="screen" href="https://s0.wp.com/wp-content/themes/pub/vigilance/stylesheets/ie6.css" /><![endif]-->
<link rel="pingback" href="https://blog.acolyer.org/xmlrpc.php" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=blog.acolyer.org&amp;id=23592848&amp;t=1508513731&amp;back=https%3A%2F%2Fblog.acolyer.org%2F2017%2F10%2F20%2Fcomputing-machinery-and-intelligence%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//adriancolyer.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="the morning paper &raquo; Feed" href="https://blog.acolyer.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="the morning paper &raquo; Comments Feed" href="https://blog.acolyer.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="the morning paper &raquo; Computing machinery and&nbsp;intelligence Comments Feed" href="https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s0.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1505864856h&ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJyNktFuwyAMRX9oHspWbevDtG8hxKVuDUbBaZq/H2kaTe0q1BfkCz4212DGBE6iYlQTBkg8eIrZjMlJgByIcbpTry7nF/MYYzpiNgfUZN0RLqqW3iNbxQ6SZL1TNYzijiLpZHSPofRLQ2tO5IltdFgDnfRY9kOyOmcE7MgilxpRa9hIncdywZJyjUHxXEVC+lgbzeG+jKNqaZlw26Yec4ayBhoCLP7+cY9sm6wTV82vLlTSdeBPI1kcWQYqKbdigclE0eVwDWpVPQqwOKsk8UbAji319Q/TsvgS+stj/MkZ+gnfzWb7+fbVNO/N4RdKIRMo' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-1-1' href='https://s0.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJx9i9EKwjAMRX/IGoVN54P4LVnp2kialCbD3xcfRGTi0z0XzoFHC1HFkzjUNTReM4kBRieVGfuH9tFsB7/1puZhYaQOVrCT5Pf+q0wjIQfWrN9nE3lJNRmUATLrjPwSbvV6HC6H83Qap/H+BMWZScE=' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFj90KwjAMhV/IrAw6xQvxWWoXS2r/bNoNfXo70At1KARCTr4cTsScgIJ2dUQWttW1Yr49W2d5I34B4MlkVbDzFF6wjqFgKAvr44kcQmXMyjStGZ3jCpciF4/MDVrZvkeiMBHOfzGLJSl9gYxM9y9XXyG5aiiwyOjaAyMsGT6mdnX0h17uh36Qcre1DyuucHk='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://adriancolyer.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Serverless computing: economic and architectural&nbsp;impact' href='https://blog.acolyer.org/2017/10/19/serverless-computing-economic-and-architectural-impact/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/" />
<link rel='shortlink' href='http://wp.me/p1AZzO-1wC' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fblog.acolyer.org%2F2017%2F10%2F20%2Fcomputing-machinery-and-intelligence%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fblog.acolyer.org%2F2017%2F10%2F20%2Fcomputing-machinery-and-intelligence%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Computing machinery and intelligence" />
<meta property="og:url" content="https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/" />
<meta property="og:description" content="Computing machinery and intelligence A.M. Turing, MIND 1950 This is most certainly a classic paper. We’ve all heard of the ‘Turing Test,’ but have you actually read the paper where Alan Turing defi…" />
<meta property="article:published_time" content="2017-10-20T05:00:00+00:00" />
<meta property="article:modified_time" content="2017-10-15T16:21:20+00:00" />
<meta property="og:site_name" content="the morning paper" />
<meta property="og:image" content="https://secure.gravatar.com/blavatar/09326a066a08237015d6b84f026d36ae?s=200&amp;ts=1508513731" />
<meta property="og:image:width" content="200" />
<meta property="og:image:height" content="200" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wordpressdotcom" />
<meta name="twitter:text:title" content="Computing machinery and&nbsp;intelligence" />
<meta name="twitter:image" content="https://secure.gravatar.com/blavatar/09326a066a08237015d6b84f026d36ae?s=240" />
<meta name="twitter:card" content="summary" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/09326a066a08237015d6b84f026d36ae?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/09326a066a08237015d6b84f026d36ae?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/09326a066a08237015d6b84f026d36ae?s=114" />
<link rel='openid.server' href='https://adriancolyer.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://adriancolyer.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://blog.acolyer.org/osd.xml" title="the morning paper" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<style id="wpcom-hotfix-masterbar-style">
			@media screen and (min-width: 783px) {
				#wpadminbar .quicklinks li#wp-admin-bar-my-account.with-avatar > a img {
					margin-top: 5px;
				}
			}
		</style>
		
	<meta name="application-name" content="the morning paper" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="an interesting/influential/important paper from the world of CS every weekday morning, as selected by Adrian Colyer" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://blog.acolyer.org/feed/;icon-uri=https://secure.gravatar.com/blavatar/09326a066a08237015d6b84f026d36ae?s=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" />	<style type="text/css">
				#title a { color: #444444 }
		</style>
<link rel="amphtml" href="https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<style type="text/css" id="custom-colors-css">.comments a{background-image:none;padding-left:0}body{color:#333}.categories a:link,.categories a:visited{color:#333}#nav li a{color:#333}#footer{color:#333}#description h2{color:#333}.post .date,.comments,.meta,.categories{color:#333}.meta a:link,.meta a:visited{color:#333}#footer a:link,#footer a:visited{color:#333}.sticky .entry{background-color:#eee}.sticky .entry{background-color:rgba(238,238,238,.1)}#footer{border-color:#6d6d6d}body{background-color:#fff}.post-header,.post-footer{border-color:#fff}#header{border-color:#b7b7b7}a:hover{color:#772124}#header #title a:hover{color:#772124}#nav ul li a:hover,#nav ul li:hover>a,#nav ul li.current_page_item>a,#nav ul li.current_page_parent>a,#nav ul li.current_page_ancestor>a,#nav ul li.current-cat>a,#nav ul li.current-menu-ancestor>a,#nav ul li.current-menu-item>a,#nav ul li.current-menu-parent a{color:#772124}#nav ul li a:hover,#nav ul li:hover>a,#nav ul li.current_page_item>a,#nav ul li.current_page_parent>a,#nav ul li.current_page_ancestor>a,#nav ul li.current-cat>a,#nav ul li.current-menu-ancestor>a,#nav ul li.current-menu-item>a,#nav ul li.current-menu-parent a{border-top-color:#772124}.post-header h1 a:hover,.post-header h2 a:hover{color:#772124}.meta a:hover{color:#772124}.comments a:hover{color:#772124}.categories a:hover{color:#772124}span.asterisk{color:#772124}#footer a:hover{color:#772124}a:link,a:visited{color:#772124}.post-header h1 a:link,.post-header h1 a:visited,.post-header h2 a:link,.post-header h2 a:visited{color:#772124}#title a{color:#772124}</style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s2.wp.com/?custom-css=1&#038;csblog=1AZzO&#038;cscache=6&#038;csrev=7" />
		</head>
<body class="post-template-default single single-post postid-5866 single-format-standard mp6 customizer-styles-applied vigilance-light highlander-enabled highlander-light custom-colors">
	<div class="skip-content"><a href="#content">Skip to content</a></div>
	<div id="wrapper">
				<div id="header" class="clear">
			<div id="title"><a href="https://blog.acolyer.org"><span>the morning paper</span></a></div>			<div id="description">
				<h2>an interesting/influential/important paper from the world of CS every weekday morning, as selected by Adrian Colyer</h2>
			</div><!--end description-->
			<div id="nav">
					<ul class="menu">
		<li class="page_item "><a href="https://blog.acolyer.org">Home</a></li>
				<li class="page_item page-item-2"><a href="https://blog.acolyer.org/about/">About</a></li>
<li class="page_item page-item-5027"><a href="https://blog.acolyer.org/infoq-quarterly-review-editions/">InfoQ QR Editions</a></li>
<li class="page_item page-item-406"><a href="https://blog.acolyer.org/email-subs/">Subscribe</a></li>
	</ul>
			</div><!--end nav-->
		</div><!--end header-->
		<div id="content" class="pad">
									<div id="post-5866" class="post-5866 post type-post status-publish format-standard hentry category-uncategorized tag-ai">
			<div class="post-header">
				<h1>Computing machinery and&nbsp;intelligence</h1>
				<div id="single-date" class="date">October 20, 2017</div>
			</div><!--end post header-->
			<div class="meta clear">
				<div class="tags">tags: <a href="https://blog.acolyer.org/tag/ai/" rel="tag">AI</a></div>
				<div class="author">
									</div>
			</div><!--end meta-->
			<div class="entry clear">
								<p><a href="http://phil415.pbworks.com/f/TuringComputing.pdf">Computing machinery and intelligence</a> A.M. Turing, <em>MIND 1950</em></p>
<p>This is most certainly a classic paper. We’ve all heard of the ‘Turing Test,’ but have you actually read the paper where Alan Turing defines it? I confess I hadn’t until recently, and there’s a whole lot more to it than I was expecting. Yes, it describes the Turning Test (Turing didn’t call it that at the time, his name was the ‘imitation game’), but it is also presents his thoughts on whether or not a digital computer can ever pass the test, and some remarkable observations on what it might take to build a learning machine given that Turing was writing in 1950! Plus, the writing style is a delight.</p>
<h3>The Imitation Game</h3>
<blockquote><p>
  I propose to consider the question, ‘Can machines think?’ This should begin with definitions of the meaning of the terms ‘machine’ and ‘think’.
</p></blockquote>
<p>To avoid the discussion degenerating into something to be settled by an opinion poll, Turing quickly refines it to a more testable proposition. The imitation game is first introduced with a man (player A) and a woman (player B) in one room, and an interrogator in another. By posing questions (in typewritten form) to the two participants, the interrogator must try to determine which of the two is the woman. The man tries to fool the interrogator into thinking he is the woman.</p>
<blockquote><p>
  We now ask the question, ‘What will happen when a machine takes the part of A in this game?’
</p></blockquote>
<p>Can the interrogator tell the difference between human and machine? This question replaces the original ‘Can machines think?’</p>
<blockquote><p>
  May not machines carry out something which ought to be described as thinking but which is very different from what a man does? This objection is a very strong one, but at least we can say that if, nevertheless, a machine can be constructed to play the imitation game satisfactorily, we need not be troubled by this objection.
</p></blockquote>
<p>The definition of machine is subsequently narrowed to mean a digital computer. “<em>We are not asking whether all digital computers would do well in the game nor whether the computers at present available would do well, but whether there are imaginable computers which would do well.</em>” After an introduction to the concept of a <em>universal</em> machine, we are permitted to focus our attention on one particular digital computer, <em>C</em>. We can modify it to have adequate storage, we can suitably increase its speed of action, and we can provide it with an appropriate programme.  Can <em>C</em> be made to play satisfactorily the part of <em>A</em> in the imitation game, the part of <em>B</em> being taken by a man?</p>
<h3>Turing’s personal belief</h3>
<blockquote><p>
  It will simplify matters for the reader if I explain first my own beliefs in the matter. Consider first the more accurate form of the question. I believe that in about fifty years’ time it will be possible to programme computers, with a storage capacity of about <img src="https://s0.wp.com/latex.php?latex=10%5E9&#038;bg=ffffff&#038;fg=333333&#038;s=0" alt="10^9" title="10^9" class="latex" /> (125MB!), to make them play the imitation game so well that an average interrogator will not have more than 70 per cent. chance of making the right identification after five minutes of questioning. The original question, ‘Can machines think?’ I believe to be too meaningless to deserve discussion.
</p></blockquote>
<p>In the original paper, Turing now proceeds to address a series of imagined objections. I’ll come back to those briefly at the end, because I want to focus first on Turing’s vision for learning machines.</p>
<h3>Towards learning machines</h3>
<blockquote><p>
  &#8230;[consider] an atomic pile of less than critical size: an injected idea is to correspond to a neutron entering the pile from without. Each such neutron will cause a certain disturbance which eventually dies away. If, however, the size of the pile is sufficiently increased, the disturbance caused by such an incoming neutron will very likely go on and on increasing until the whole pile is destroyed. Is there a corresponding phenomenon for minds, and is there one for machines?
</p></blockquote>
<p>If you present an idea to most minds, you get less than one idea back. But a smallish proportion of minds are <em>super-critical</em>, and an idea presented to such a mind may give rise to a whole ‘theory’ with secondary, tertiary, and more remote ideas&#8230; <em>can a machine be made to be super-critical?</em> It’s not the storage or the speed that will be the problem argues Turing, but the <em>programming</em>.</p>
<p>Think about an adult mind: how did it arrive at its current state?</p>
<blockquote><p>
  We may notice three components, (a) the initial state of the mind, say at birth, (b) the education to which it has been subjected, (c) other experience, not to be described as education, to which it has been subjected. Instead of trying to produce a programme to simulate the adult mind, why not rather try to produce one that simulates the childs! &#8230; We have thus divided our problem into two parts. The child-programme and the education process.
</p></blockquote>
<p>We won’t find a good child machine at the first attempt, but Turing suggests we may be able to find one through a process of experimentation and evolution. Let the structure of the child machine be the equivalent of hereditary material, changes to the machine be mutations, and the role of natural selection be played by the judgement of the experimenter.</p>
<blockquote><p>
  One may hope, however, that this process will be more expeditious than evolution. The survival of the fittest is a slow method for measuring advantages. The experimenter, by the exercise of intelligence, should be able to speed it up.
</p></blockquote>
<p>For the core of the education process, Turing suggests a form of reinforcement learning: “the machine has to be so constructed that events which shortly preceded the occurrence of a punishment-signal are unlikely to be repeated, whereas a reward-signal increased the probability of repetition of the events which led up to it.” And, “these definitions do not pre-suppose any feelings on the part of the machine.”</p>
<p>But reinforcement learning on its own will not be enough. Think how long it would take to a pupil to repeat ‘Casabianca’ if only rewards and punishments could be given for utterances. We need some additional channels of communication, for example, a <em>symbolic language</em>.</p>
<blockquote><p>
  Opinions may vary as to the complexity which is suitable in the child machine. One might try to make it as simple as possible consistently with the general principles. Alternatively one might have a complete system of logical inference ‘built in’.
</p></blockquote>
<p>It will be most important, Turing says, to regulate the order in which the rules of the logical system concerned are to be applied. For herein lies the difference between a brilliant and a footling reasoner (not the difference between an sound and a fallacious one).</p>
<p>Does it matter if we understand the inner workings of such a machine?</p>
<blockquote><p>
  An important feature of a learning machine is that its teacher will often be very largely ignorant of quite what is going on inside, although he may still be able to some extent to predict his pupil’s behaviour. This should apply most strongly to the later education of a machine arising from a child-machine of well-tried design (or programme).
</p></blockquote>
<p>It will also help if a learning machine includes a random element. “A random element is rather useful when we are searching for a solution of some problem.”</p>
<h3>Objections to thinking machines</h3>
<p>Turing considers (and dismisses) 9 possible objections to the idea that a machine may someday be successful in the imitation game. We don’t have the space here to go into them, although they are full of character and worth reading if you have the inclination. In brief they are:</p>
<ol>
<li>The theological objection &#8211; thinking is a function of the immortal soul, and only God can create a soul. (“I am not very impressed with theological arguments. Such arguments have often been found unsatisfactory in the past.” E.g., Galileo). </li>
<li>The ‘heads in the sand’ objection &#8211; the consequences would be too dreadful, so let us hope and believe it’s not possible. (“&#8230; not sufficiently substantial to require refutation”).</li>
<li>The mathematical objection &#8211; Godel’s theorem, and results from Church, Kleen, Rosser, and Turing show that there are limitations to the powers of discrete state machines. (“&#8230; but it has only been stated, without any sort of proof, that no such limitations apply to the human intellect. But I do not think this view can be dismissed quite so lightly.”)</li>
<li>The argument from consciousness &#8211; “Yes, but can a machine really <em>feel</em>.”  (“This argument appears to be a denial of the validity of our test.”)</li>
<li>Arguments from various disabilities &#8211; you will never be able to make a machine do X (e.g., enjoy strawberries and cream). (Mostly limited imagination based on the machines people have seen so far). </li>
<li>Lady Lovelace’s objection &#8211; the machine can do whatever we know how to order it to perform (with an implied ‘only’ before the do). A variant of this objection is that a machine can never take you by surprise. (“Machines take me by surprise with great frequency”).</li>
<li>Argument from continuity in the nervous system &#8211; the nervous system is not a discrete-state machine (“&#8230; the interrogator will not be able to take any advantage of this difference.”)</li>
<li>Argument from informality of behaviour &#8211; you can’t describe an explicit set of rules for all situations. (“ ‘&#8230; there are no such rules so men cannot be machines.’ The undistributed middle is glaring.”)</li>
<li>Argument from extra-sensory perception (“If telepathy is admitted&#8230; then putting the competitors into a ‘telepathy-proof room’ would satisfy all the requirements.”)</li>
</ol>
<h3>In conclusion</h3>
<blockquote><p>
  We may hope that machines will eventually compete with men in all purely intellectual fields. But which are the best ones to start with? Even this is a difficult decision. Many people think that a very abstract activity, like the playing of chess, would be best. It can also be maintained that it is best to provide the machine with the best sense organs that money can buy, and then teach it to understand and speak English&#8230; Again I do not know what the right answer is, but I think both approaches should be tried.
</p></blockquote>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-5866" class="share-twitter sd-button share-icon" href="https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-5866" class="share-linkedin sd-button share-icon" href="https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/?share=email" target="_blank" title="Click to email"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-23592848-5866-59ea17c3df32e' data-src='//widgets.wp.com/likes/#blog_id=23592848&amp;post_id=5866&amp;origin=adriancolyer.wordpress.com&amp;obj_id=23592848-5866-59ea17c3df32e' data-name='like-post-frame-23592848-5866-59ea17c3df32e'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>											</div><!--end entry-->
			<div class="post-footer">
				<div class="categories">from &rarr; <a href="https://blog.acolyer.org/category/uncategorized/" rel="category tag">Uncategorized</a></div>
			</div><!--end post footer-->
		</div><!--end post-->
				<div class="navigation post single clear">
			<div class="alignleft"><a href="https://blog.acolyer.org/2017/10/19/serverless-computing-economic-and-architectural-impact/" rel="prev">&larr; Serverless computing: economic and architectural&nbsp;impact</a></div>
			<div class="alignright" ></div>
		</div><!--end pagination-->
		<!-- You can start editing here. -->
<div id="comments">
	<div class="comment-number">
		<span>3 Comments</span>
			<a id="leavecomment" href="#respond" title="Leave One">leave one &rarr;</a>
		</div><!--end comment-number-->
			<ol class="commentlist">
			
			<li class="comment byuser comment-author-themaqbool even thread-even depth-1 highlander-comment" id="comment-17053" >
			<div class="c-grav"><img alt='' src='https://1.gravatar.com/avatar/13d3aea89d4b5ba2cd1fa0c88d3038f5?s=60&#038;d=identicon&#038;r=G' class='avatar avatar-60' height='60' width='60' /></div>
				<div class="c-body">
					<div class="c-head">
						<a href='http://www.maqbool.net' rel='external nofollow' class='url'>Maqbool</a> <span class="c-permalink"><a href="https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/#comment-17053">permalink</a></span>					</div>
					<div class="c-date">
						October 20, 2017 7:57 am					</div>
										<p>Reblogged this on <a href="https://maqboolblog.wordpress.com/2017/10/20/computing-machinery-and-intelligence/" rel="nofollow">Mohd Maqbool Alam</a>.</p>
										<div class="reply">
						<a rel='nofollow' class='comment-reply-link' href='https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/?replytocom=17053#respond' onclick='return addComment.moveForm( "comment-17053", "17053", "respond", "5866" )' aria-label='Reply to Maqbool'>Reply</a>					</div>
									</div><!--end c-body-->
</li><!-- #comment-## -->

			<li class="comment byuser comment-author-zteve odd alt thread-odd thread-alt depth-1 highlander-comment" id="comment-17057" >
			<div class="c-grav"><img alt='' src='https://2.gravatar.com/avatar/8b7f3a1367b24335691b1af5397f1a67?s=60&#038;d=identicon&#038;r=G' class='avatar avatar-60' height='60' width='60' /></div>
				<div class="c-body">
					<div class="c-head">
						Zteve <span class="c-permalink"><a href="https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/#comment-17057">permalink</a></span>					</div>
					<div class="c-date">
						October 20, 2017 11:52 am					</div>
										<p>&gt; Argument from extra-sensory perception (“If telepathy is admitted… </p>
<p>Turing says “Unfortunately the statistical evidence, at least for telepathy, is overwhelming.” I&#8217;m not sure we could find many scientists who would agree with this today, but even so Turing&#8217;s remedy is masterly—simply to eliminate its possible effects from the test.</p>
										<div class="reply">
						<a rel='nofollow' class='comment-reply-link' href='https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/?replytocom=17057#respond' onclick='return addComment.moveForm( "comment-17057", "17057", "respond", "5866" )' aria-label='Reply to Zteve'>Reply</a>					</div>
									</div><!--end c-body-->
</li><!-- #comment-## -->

			<li class="comment byuser comment-author-parnas2014 even thread-even depth-1 highlander-comment" id="comment-17064" >
			<div class="c-grav"><img alt='' src='https://0.gravatar.com/avatar/68b0306b923745d76967326257ce4212?s=60&#038;d=identicon&#038;r=G' class='avatar avatar-60' height='60' width='60' /></div>
				<div class="c-body">
					<div class="c-head">
						<a href='http://dlpblogge.wordpress.com' rel='external nofollow' class='url'>parnas2014</a> <span class="c-permalink"><a href="https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/#comment-17064">permalink</a></span>					</div>
					<div class="c-date">
						October 20, 2017 2:15 pm					</div>
										<p>Glad to see that someone actually read that paper.  What do you think of this one? </p>
<p>Dave Parnas </p>
<p>&gt;</p>
										<div class="reply">
						<a rel='nofollow' class='comment-reply-link' href='https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/?replytocom=17064#respond' onclick='return addComment.moveForm( "comment-17064", "17064", "respond", "5866" )' aria-label='Reply to parnas2014'>Reply</a>					</div>
									</div><!--end c-body-->
</li><!-- #comment-## -->
		</ol>
		<div class="navigation">
		<div class="alignleft"></div>
		<div class="alignright"></div>
	</div>
		</div><!--end comments-->

	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/10/20/computing-machinery-and-intelligence/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://blog.acolyer.org/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="3705280b1d" /><input type="hidden" name="_wp_http_referer" value="/2017/10/20/computing-machinery-and-intelligence/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='5866' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a9d264fade" /></p>
<input type="hidden" name="genseq" value="1508513731" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="108"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>			</div><!--end content-->
	<div id="sidebar">
																		<ul class="thin-sidebar">			<li id="text-4" class="widget widget_text"><h2 class="widgettitle">Subscribe </h2>			<div class="textwidget"><div align="center">
<a href="http://eepurl.com/bbzPm9"><img src="https://adriancolyer.files.wordpress.com/2015/01/mail-new-icon.png?w=600"></a>
<br />never miss an issue! The Morning Paper delivered straight to your inbox.
</div></div>
		</li><li id="search-3" class="widget widget_search"><h2 class="widgettitle">Search</h2><form method="get" id="search_form" action="https://blog.acolyer.org/">
	<div>
		<input type="text" value="type and press enter" name="s" id="s" onfocus="if (this.value == 'type and press enter') {this.value = '';}" onblur="if (this.value == '') {this.value = 'type and press enter';}" />
		<input type="hidden" value="Search" />
	</div>
</form></li><li id="archives-3" class="widget widget_archive"><h2 class="widgettitle">Archives</h2>		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='https://blog.acolyer.org/2017/10/'> October 2017 &nbsp;(15)</option>
	<option value='https://blog.acolyer.org/2017/09/'> September 2017 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2017/08/'> August 2017 &nbsp;(19)</option>
	<option value='https://blog.acolyer.org/2017/07/'> July 2017 &nbsp;(6)</option>
	<option value='https://blog.acolyer.org/2017/06/'> June 2017 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2017/05/'> May 2017 &nbsp;(23)</option>
	<option value='https://blog.acolyer.org/2017/04/'> April 2017 &nbsp;(11)</option>
	<option value='https://blog.acolyer.org/2017/03/'> March 2017 &nbsp;(23)</option>
	<option value='https://blog.acolyer.org/2017/02/'> February 2017 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2017/01/'> January 2017 &nbsp;(25)</option>
	<option value='https://blog.acolyer.org/2016/12/'> December 2016 &nbsp;(14)</option>
	<option value='https://blog.acolyer.org/2016/11/'> November 2016 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2016/10/'> October 2016 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2016/09/'> September 2016 &nbsp;(20)</option>
	<option value='https://blog.acolyer.org/2016/07/'> July 2016 &nbsp;(16)</option>
	<option value='https://blog.acolyer.org/2016/06/'> June 2016 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2016/05/'> May 2016 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2016/04/'> April 2016 &nbsp;(12)</option>
	<option value='https://blog.acolyer.org/2016/03/'> March 2016 &nbsp;(23)</option>
	<option value='https://blog.acolyer.org/2016/02/'> February 2016 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2016/01/'> January 2016 &nbsp;(23)</option>
	<option value='https://blog.acolyer.org/2015/12/'> December 2015 &nbsp;(10)</option>
	<option value='https://blog.acolyer.org/2015/11/'> November 2015 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2015/10/'> October 2015 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2015/09/'> September 2015 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2015/08/'> August 2015 &nbsp;(22)</option>
	<option value='https://blog.acolyer.org/2015/06/'> June 2015 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2015/05/'> May 2015 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2015/04/'> April 2015 &nbsp;(14)</option>
	<option value='https://blog.acolyer.org/2015/03/'> March 2015 &nbsp;(23)</option>
	<option value='https://blog.acolyer.org/2015/02/'> February 2015 &nbsp;(23)</option>
	<option value='https://blog.acolyer.org/2015/01/'> January 2015 &nbsp;(21)</option>
	<option value='https://blog.acolyer.org/2014/12/'> December 2014 &nbsp;(15)</option>
	<option value='https://blog.acolyer.org/2014/11/'> November 2014 &nbsp;(20)</option>
	<option value='https://blog.acolyer.org/2014/10/'> October 2014 &nbsp;(20)</option>
	<option value='https://blog.acolyer.org/2011/05/'> May 2011 &nbsp;(3)</option>

		</select>
		</li><li id="top-posts-3" class="widget widget_top-posts"><h2 class="widgettitle">Most read in the last few days</h2><ul>				<li>
										<a href="https://blog.acolyer.org/2017/10/19/serverless-computing-economic-and-architectural-impact/" class="bump-view" data-bump-view="tp">
						Serverless computing: economic and architectural impact					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/10/13/badnets-identifying-vulnerabilities-in-the-machine-learning-model-supply-chain/" class="bump-view" data-bump-view="tp">
						BadNets: Identifying vulnerabilities in the machine learning model supply chain					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/10/18/on-understanding-software-agility-a-social-complexity-point-of-view/" class="bump-view" data-bump-view="tp">
						On understanding software agility - a social complexity point of view					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/10/17/the-new-dynamics-of-strategy-sense-making-in-a-complex-and-complicated-world/" class="bump-view" data-bump-view="tp">
						The new dynamics of strategy: sense-making in a complex and complicated world					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/10/20/computing-machinery-and-intelligence/" class="bump-view" data-bump-view="tp">
						Computing machinery and intelligence					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/09/19/to-type-or-not-to-type-quantifying-detectable-bugs-in-javascript/" class="bump-view" data-bump-view="tp">
						To type or not to type: quantifying detectable bugs in JavaScript					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2016/04/21/the-amazing-power-of-word-vectors/" class="bump-view" data-bump-view="tp">
						The amazing power of word vectors					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/09/25/a-dirty-dozen-twelve-common-metric-interpretation-pitfalls-in-online-controlled-experiments/" class="bump-view" data-bump-view="tp">
						A dirty dozen: twelve common metric interpretation pitfalls in online controlled experiments					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/09/21/clkscrew-exposing-the-perils-of-security-oblivious-energy-management/" class="bump-view" data-bump-view="tp">
						CLKSCREW: Exposing the perils of security-oblivious energy management					</a>
									</li>
							<li>
										<a href="https://blog.acolyer.org/2017/10/03/tfx-a-tensorflow-based-production-scale-machine-learning-platform/" class="bump-view" data-bump-view="tp">
						TFX: A TensorFlow-based production scale machine learning platform					</a>
									</li>
			</ul></li><li id="rss_links-3" class="widget widget_rss_links"><h2 class="widgettitle">RSS</h2><ul><li><a href="https://blog.acolyer.org/feed/" title="Subscribe to Posts">RSS - Posts</a></li><li><a href="https://blog.acolyer.org/comments/feed/" title="Subscribe to Comments">RSS - Comments</a></li></ul>
</li><li id="twitter_timeline-3" class="widget widget_twitter_timeline"><h2 class="widgettitle">Live on twitter</h2><a class="twitter-timeline" data-width="225" data-height="400" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-tweet-limit="10" data-lang="EN" data-partner="jetpack" data-widget-id="519408925733425153">My Tweets</a></li>		</ul>	</div><!--end sidebar-->	<div id="footer">
		<div class="footer-liner">
			<p class="right"><a href="https://wordpress.com/?ref=footer_blog">Blog at WordPress.com.</a></p>
			<p></p>
		</div><!-- .footer-liner -->
	</div><!--end footer-->
</div><!--end wrapper-->
<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201742y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-13d3aea89d4b5ba2cd1fa0c88d3038f5">
	</div>
	<div class="grofile-hash-map-8b7f3a1367b24335691b1af5397f1a67">
	</div>
	<div class="grofile-hash-map-68b0306b923745d76967326257ce4212">
	</div>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/adriancolyer.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/adriancolyer.wordpress.com\/wp-login.php?action=logout&_wpnonce=4a5db4a2f9","homeURL":"https:\/\/blog.acolyer.org\/","postID":"5866","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="23592848" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://blog.acolyer.org" />
				<input type="hidden" id="carousel-reblog-blog-title" value="the morning paper" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="96ddf092ee" /><input type="hidden" name="_wp_http_referer" value="/2017/10/20/computing-machinery-and-intelligence/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.acolyer.org\/2017\/10\/20\/computing-machinery-and-intelligence\/":5866};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-linkedin' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
		});
		</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/10/20/computing-machinery-and-intelligence/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			<div class="recaptcha" id="sharing_recaptcha"></div><input type="hidden" name="recaptcha_public_key" id="recaptcha_public_key" value="6LcYW8MSAAAAADBAuEH9yaPcF7lWh11Iq62ZKtoo" />
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546h' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"23592848","siteName":"the morning paper","siteURL":"https:\/\/blog.acolyer.org","icon":"<img alt='' src='https:\/\/secure.gravatar.com\/blavatar\/09326a066a08237015d6b84f026d36ae?s=50&d=https%3A%2F%2Fs1.wp.com%2Fi%2Flogo%2Fwpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/vigilance","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/adriancolyer.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.acolyer.org%2F2017%2F10%2F20%2Fcomputing-machinery-and-intelligence%2F","themeURL":"","xhrURL":"https:\/\/blog.acolyer.org\/wp-admin\/admin-ajax.php","nonce":"9d295632e3","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"6a836ba985\" \/>","referer":"https:\/\/blog.acolyer.org\/2017\/10\/20\/computing-machinery-and-intelligence\/","canFollow":"1","feedID":"25337874","statusMessage":"","customizeLink":"https:\/\/adriancolyer.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fadriancolyer.wordpress.com%2F2017%2F10%2F20%2Fcomputing-machinery-and-intelligence%2F","postID":"5866","shortlink":"http:\/\/wp.me\/p1AZzO-1wC","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/blog.acolyer.org\/5866","statsLink":"https:\/\/wordpress.com\/stats\/post\/5866\/blog.acolyer.org","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Vigilance","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 1,386 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/adriancolyer.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.acolyer.org%2F2017%2F10%2F20%2Fcomputing-machinery-and-intelligence%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.acolyer.org\/wp-admin\/admin-ajax.php","nonce":"747e0bf1cd","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/adriancolyer.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.acolyer.org%2F2017%2F10%2F20%2Fcomputing-machinery-and-intelligence%2F","blog_id":"23592848","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=23592848&v=wpcom&tz=1&user_id=0&subd=adriancolyer","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJx9UMtSwzAM/CEcpWUKXBg+hTGO2srxC0lu6d/XHUjJoeOTNKvd1UpwLsblpJgUvMCEJ3JYfgYvT7AaxWpKqAdKAoFmFPiuWPFo0xSQFzIlF+rUhs3I5Rib0DCWcBkipY6jRy3WzfDZDEDPpIpslCIGStjR2an5mi/LEK00TetMPiEz3ULcsZ6DU8rp5nDvHh0j5T//GvftC3z5K8Oa9WCXs5yrYFjONQvQyzeTRFTzPIy/39lnjh1+yaJmHywxyNEypcNSm+gjvm924/blbfO6Hf0VhlW8gQ=='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'23592848','blog_tz':'1','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'23592848','v':'wpcom','tz':'1','user_id':'0','post':'5866','subd':'adriancolyer'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGRVYVNrSFguN3FwSmQ5RGtNX3VQcj1yVzhiflM1THQtLGFdQ2toOXYlNCVaeklqTUlaNm1kY3ZwbnZlLFpPP2pvM0ZDJnddMFdiNndIMGE0Z0xkRSxyNWx6a1VIMXw1Smd5fiZWUGszfjNGSEh8cysteklmR1VofjlLOVFhLUlNPzltUzZHUS0vbnJMP0dPLGY/U1VhfDkvLGlxbkQ/MFFORnY/S1l0Vi9GdGZ1ayxfenE1dG5rTlhqaEctZjJMcXp+L1lnOVZBSGF8NE1QKyw1PWI0VjBdQXQ5RnpvPUdaXT9kW3YmUTMrJnhYZE4yU1l+Ll1BN1lPejJSPUNhRGhSbUl1MkM9Nm5+W2szJm5GRlY5Zzd5TU1kOWJTazR4TE5LTi1lX21SLjI='}]);
_stq.push([ 'clickTrackerInit', '23592848', '5866' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>
<!--
	generated 81 seconds ago
	generated in 0.120 seconds
	served from batcache in 0.001 seconds
	expires in 219 seconds
-->
